Porsche Enthusiasts Club Forum

It is currently Sat Jun 12, 2021 6:21 pm
Classic Line Insurance


All times are UTC [ DST ]




Post new topic Reply to topic  [ 4 posts ] 
Author Message
 Post subject: strange electrical issue with my 944
PostPosted: Sat Mar 06, 2021 9:24 am 
Offline

Joined: Wed Nov 14, 2018 11:14 pm
Posts: 15
TIPEC membership: 0
I replaced the voltage regulator on my 944 as it was worn out and since then I've been getting this strange thing.. when I go to start the car it will regularly just cut all the power... Everything dies. I have to disconnect and reconnect the battery to get another go of starting it. As soon as the battery is disconnected and reconnected voltage is restored and I can start it. After a few attempts it invariably starts.

Anyone every heard of anything like this happening. The voltage regulator was a good quality one and it did fix the problem I was having with voltage fluctuation from the old worn out one.


Top
 Profile  
Reply with quote  
 Post subject: Re: strange electrical issue with my 944
PostPosted: Sat Mar 06, 2021 12:41 pm 
Offline

Joined: Wed May 27, 2015 9:03 pm
Posts: 34
TIPEC membership: 0
Possibly a faulty earth which may of damaged the reg initially also


Top
 Profile  
Reply with quote  
 Post subject: Re: strange electrical issue with my 944
PostPosted: Sat Mar 06, 2021 1:01 pm 
Offline

Joined: Wed Nov 14, 2018 11:14 pm
Posts: 15
TIPEC membership: 0
And now she won't start... no spark. DME seems to be fine as getting 12v pulse to the injectors and the coil on turnover. Fuel pump all good.. DME relay ruled out. When you turnover there is a discernable voltage drop on the cockpit voltmeter to 8v. Battery fully charged and brand new a few weeks ago.
Removed the new voltage regulator and there is uneven wear like the prongs are not riding smoothly on the rotating contacts inside the alternator.

I checked the resistance across positive and negative on the ignition coil and it was reading about 1ohm, not .6 as suggested elsewhere but feels like this could be a red herring.

Anyone had issues with replacing the voltage regulator as it was a real pain when I first installed it with having to reseat it in the alternator a number of times before the car would start.


Top
 Profile  
Reply with quote  
 Post subject: Re: strange electrical issue with my 944
PostPosted: Sat Mar 06, 2021 1:04 pm 
Offline

Joined: Wed Nov 14, 2018 11:14 pm
Posts: 15
TIPEC membership: 0
Thanks for this.. I just wonder if the alternator is a bit worn to take a new regulator. The regulator just doesn't seem to want to sit nicely on the two rotating contacts


Top
 Profile  
Reply with quote  
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 4 posts ] 

All times are UTC [ DST ]


Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group